D-Link DSL-G624T Wireless 4-Port ADSL Router – 支援討論區

"Modem not detected" on ADSL connection [D-Link DSL-G624T Wireless 4-Port ADSL Router - 137713]

  • iwilliams
  • 投稿: 2
  • 註冊日期: 18 九月 2006
Hi, I run the wizard to "Quick Install" the D-Link DSL-G624T Wireless ADSL router, and I get as far as it "checking physical connectivity" - but it stops with "Modem not detected" every time. The broadband connection works fine with the cheapy USB modem supplied by the broadband company. Any suggestions appreciated. Thanks Ian
  • awebster
  • 投稿: 2
  • 註冊日期: 30 九月 2006
Hey man i get isacally the same problem. can any one help me out?? williams let me know if u sorted your problem thank you
  • [Cas]
  • 投稿: 4
  • 註冊日期: 25 九月 2006
what isp are you using? only thing i can think off-hand is it could need alternative settings for the adsl. just for reference ill put the settings from mine down VPI: 0 VCI: 38 Wan Setting: PPPoE/PPPoA Username (inc @ part) Auth Type: Auto Conn Type: PPPoA VC-Mux
  • awebster
  • 投稿: 2
  • 註冊日期: 30 九月 2006
i get this sorted problem was my network card wasent responding for some odd reason so i put a new network card inn and got it working.
  • sebsone
  • 投稿: 1
  • 註冊日期: 16 十二月 2006
I got the same problem. I have a D-Link DSL-G624T, and as I turn it on, the WLAN (wireless Link/Act)led doesn''t turn on ever again, although the portable pc of my friend is always on. So now, when I launch the quick install I get as far as it "checking physical connectivity" - but it stops with "Modem not detected" every time, although the POWER, STATUS, LAN leds are all functioning as they should, and the cables work well (I''m sure of that). It all happend in the following peculiar context: I was emuling under XP AND playing an old game via DOSBOX emulator (which simulates MS-DOS environment). So while playing that game on dosbox, it started fine all fine (the leds were fuctioning), but after a second look, I noticed the STAUS led of the (supposedly emuling) router being STEADY ON WITHOUT BLINKING (it should blink always). So I quit the DOSBOX game to see what was happening: Tried to restart emule, but somehow my ports rule was disfunctioning getting lowID. So I just tried to set up a new filtering rule, allowing the needed ports.... So I tried to access the 192.168.1.1 administration pages of the router, but I got a strange error message saying "internal socket error" on a white page. and the browser was behaving very badly and slowly...I couldn''t get the router to work ever since. In fact, after that episode the following always happens: - can''t access the web based administration pages through 192.168.1.1 (that''s frustrating!!!) - windows always tells I''m under limited or non existing connectivity - the WLAN led never turned on again. It seems to be off permanently (even with the other computer, i.e. the Wifi laptop on), although other led seems to work well. - Can''t use the factory reset button (it doesn''t seem to have any effects anymore, even when holding it for one minute or more, or,even powering it on while holding reset button) - use the router IN ANY WAY (internet or not), even for non Wireless/ WLAN needs - use the provided Quick install application (that never gets past "checking physical connectivity", as I explained before). - find any help on the web, although I''m apparently not the only one having this kind of "modem not detected"-problem. - find out what "iternal socket error" means (I don''t really care about this one, but it could give a hint to a possible solution). For writing this post I am currently using a non WLAN DSL 300T D_link, which seems to be working allright. I am using the latest XP-SP2 updates, and I have set WIN on "obtain IP automatically". My pc and my network card work fine, that''s why I don''t believe in getting a new network card or changing windows configs, since its the same for the nonworking g624t discussed here (I even reformatted the OS drive, but still all the same). I rather have other ideas about it: I have read about so called "bricked routers", and I think that or something similar might be the case. I would like to know if I could reset the modem manually, i.e. manually by opening it and doing a short circuit with a pen on a circuit pin or something while turning the router on...I''m not afraid of doing so, however I need to know exactly which circuit pins I should shortcircuit, otherwise I might damage something (perhaps even myself??). Otherwise, I''d like to know if there is a way to acces any kind of NON-webbased administration shell/menu, or doing it all "the roots way" without any web based functionality. Would installing new firmware help anything? If yes, how can I install it without the web based administration pages? I''m glad that there is a belgian page for this, because I''m belgian myself, so feel free to write in french/dutch/german/english, because I understand them indifferently :) I really would appreciate a helping expert''s hand !! Yours faithfully, Seb
  • cdrwolfe
  • 投稿: 1
  • 註冊日期: 11 一月 2007
Same thing has happend to me, I just added a new static IP address making it two then rebooted and the router no longer works. i always get "Modem not detected" when running the CD despite having all lights on but WAN. I can''t reset as that won''t work and from what i''ve read this has happend to other people aswell. Surely a company wouldn''t release something which dies on you after adding a static IP, Dlink aren''t that incompetent are they? Anyone found a solution?
  • kevano22
  • 投稿: 1
  • 註冊日期: 26 一月 2007
Im also having the EXACT same problems as Sebsone has posted. I''ve been struggling to find a solution for over 5 hours. I''ve had to plug in my old modem to find out whats going on with it! Has anyone found a solution? Could it be the router is just "bricked"?
  • Soulja1985
  • 投稿: 1
  • 註冊日期: 17 六月 2008
I'm having the same problem, has anyone found a fix?

Hey guys,

I have got that very same router. I ran into the Wireless lan light not blinking when I tried to upgrade to the latest firmware. The upgrade went well but the wireless lan went dead for some reason. Reset the router and it will come back to life.

 

"Disconnect the power to the router, then plug it back in and wait 20 seconds. Then, hold the Reset switch on the back for 10 seconds." Wait a while and you should get the relative lights back on.

 

Hope its helps.

 

Best Regards,

Mushtaq Ilyas

;