Fortuna GPSmartBT – 支援討論區

Firmware 2.26 and timeout on windows xp sp2 [Fortuna GPSmartBT - 105113]

Hi, I would like to update the firmware from 2.25 to 2.26 avaible here : http://www.fortuna.com.tw/Support.htm I use Windows XP SP2 + fortuna usb cable. If I connect gpsmart to my PC and use sirfdemo (http://www.sirf.com/techlibrary/SSII_SDK/SSIIsdk.html) everything work properly. But if I want to use fortunasync folowing theses steps: I select refresh and browse to locate firmware 2.26 file. I Switch ON "comm port on/off" to port 5 I active "link to fortuna gps" and finaly clic "execute refresh" button. a Warning panel appear asking to wait... After 10 minutes a new message appear with "TIMOUT" I disable antivirus and firewall... anybody have a idea ?
  • DeeJayX
  • 投稿: 30
  • 註冊日期: 11 三月 2004
Firstly, I assume that from using SiRFDemo you know that Comm Port 5 is where your usb/serial adaptor has been installed? After that, 2 suggestions, both arising from documentation on the Fortuna Tech Support site. ============================================================ Using FortunaSync: What happens if you do things in THIS order 1. Select Comm Port 2. Comm Port OFF to ON; 3. Link to Fortuna GPS 4. Select REFESH and locate the 2_26.s file 5. Click Execute-Refresh ============================= Another way is to use SiRFDemo and SiRFflash, as documented at - "http://fortuna.com.tw/download/Firmware update case close.zip" (Although that file contains a copy of the V2.24_UK.s firmware, the same method works for the 2_26.s firmware.) ================================== Good luck DeeJay
  • v8manuk
  • 投稿: 4
  • 註冊日期: 17 十二月 2004
I now have same problem, I have tried the SIRF flash and get message Target not responding. Is this only resolved by returning unit to vendor?
  • RoSt
  • 投稿: 1
  • 註冊日期: 16 八月 2005
I had the same problem of the timeout and when looking in the result file c:program files\fortuna\ConsFile the following message appears > Option GPSmart\GPSamrtV2_26.s not recognized It seems the program can not handle the pathname of the location of the file So I placed the file in the same directory as the program which will do the job (SiRFflashcl.exe) found in C:Program Files\Fortuna So i First tried to run this program directly without using the Fortuna Sync Program but i then got the message Target not responding I started the fortuna sync program as written in the documents but i did not use the file browser to locate the file I manually put in the filename: GPSamrtV2_26.s (i had placed this in the same dir) After this the Firmware upgrade worked for me. Hope this wil help
  • kwadruppel
  • 投稿: 4
  • 註冊日期: 16 八月 2005
  • 地點: behind a gps
> Another way is to use SiRFDemo and SiRFflash, as documented > at - > "http://fortuna.com.tw/download/Firmware update case close.zip" i literally just flashed to 2.26 using this instruction (after identical problems as in topic start). However, one of the steps "Synchronize Protocol & Baud Rate" confused me. Although that synchronize did work, i don't think it switched my gpsmart to sirfmode, because later on in sirfflash i got a 'target not responding'. So instead of the sync i just did a 'Switch to SiRF Protocol' instead, subsequenly followed by the '94' command and a succesful flash. (another thing: to get the gpsmart to respond again after timeouts and ' not responding' errors, i left it 5 minutes without batteries, then it booted again normally with the fortuna logo anim etc.) HTH2 :)

The world is a large place to live in the people in the world all are different and it is impossible that we could meet each and every individual and learn something about him or her soo getting personal statement writing service about different regions could make it easier.

;